When searching for users in the Manage Permissions tab of the Management Console, the following error can occur:
LDAP search failed: The number of search results exceeds the Active Directory limit. Modify your search to limit the number of results.
Additionally, the following error is logged in the Assets Server log file:
[LDAP: error code 4 - Sizelimit Exceeded]
Cause
This can happen when users are managed in LDAP and the search returns more than 1,000 results.
Note: A typical scenario in which more than 1,000 results are returned is when no search term is entered in the search box.
This limitation of 1,000 results is a default setting in LDAP.
Solution
The easiest solution is to enter a search term in the search box. This will very likely keep the number of search results below 1,000.
Alternatively, increase the number of search results that LDAP can handle per query. For information about how to do this, see the LDAP documentation: '[ERROR 4] Sizelimit exceeded' problem.
Note: One of the solutions given is to change the MaxPageSize setting. Additional background information can be found on JefTek.com: Avoid changing the MaxPageSize LDAP query policy.
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