Skip to main content

Elvis queries using URL from web client

Answered

Comments

11 comments

  • Jim Meyer

    Thank you for your feedback...  I will look at adding this feature to a future release.

    In the meantime, starting with Mover 10.1.0 you can use relative dates in an Elvis query although it is not as clean as your suggestion.  See Appendix C of the Smart Mover User Guide.

    1
  • Peter Gersmann

    Hi Jim,

    Thanks for looking into this. Doesn't have to be the "parse URL" method. If I could just paste a query then it would save hours and make us able to use Smart Mover for more tasks. The SOAP method feels like using an old HP calculator. 

    /Peter

    2
  • Jim Meyer

    Peter please see:  https://helpcenter.woodwing.com/hc/en-us/articles/360021630871?flash_digest=82fdb43a00aa6c6bb66eab35fb3b51877064112c

    Note that you can paste the query string from the Pro Client and not the URL....   The URL is not valid via the REST API.

    1
  • Peter Gersmann

    Looking good!!! I do understand that the URL isn't valid with the REST API but it certainly would make it easy to use. This is so much better than the SOAP based syntax.

    0
  • Jim Meyer

    I consulted with Jaap on this and he advised against trying to use the URL...  it would be be difficult to get it to work correctly and Mover's code could easily be broken with future Elvis releases.

    0
  • Peter Gersmann

    Hi Jim,

    Does it work with Elvis 5? I get "Not logged in" - even when trying with a super user.

    /Peter

    0
  • Jim Meyer

    Yes, it should.....  what exact version of Elvis are you using?

    (I am traveling today and may not be able to respond until Feb 1)

     

    0
  • Peter Gersmann

    We're using 5.27.8. I can search for pony, tif, aa. Searching for "jpg" returns "not logged in" while searching for ".jpg" returns "Invalid Query Response!" - all query strings without quotes.

    My query: importPending:true assetCreated:<NOW-1h

    0
  • Jim Meyer

    Peter....

    Just tested with Elvis 5.27.13.253 and did not encounter any problems.

    A few questions:

    1.  Which Mover Task are you using?

    2.  Does the error occur on all Elvis related Mover Tasks?

    3.  Do you get the error when you hit the Test button on the Task setup window, when you actually run the Process or both?

    4.  Can you send screen shots of the Mover Task so I can see exactly how it is set up?  (send to info@varsitysystems.com)

    5.  Can you upgrade to 5.27.13?

     

    0
  • Jim Meyer

    Peter one more question:  Does the Elvis log include any more info on the problem?

    0
  • Peter Gersmann

    Just for those reading - this is being checked by our WoodWing partner, A+F.

    0

Please sign in to leave a comment.

Post ID: 360032333552

Created at: 2018-11-26 15:00:48 UTC

Updated at: 2019-03-18 10:26:06 UTC

Edited at:

Comment count: 11

Follower count: 2

Vote sum: 3

Vote count: 3

Status: answered