WoodWing Help Center

Opening placed database images for editing using Smart Connection

Opening placed database images for editing using Smart Connection

It is very common that a placed database image (stored in Enterprise) needs to be edited at various times during the production process. This can be quickly and efficiently done by using the Edit Original option in InDesign and InCopy.

Note: For information about how to place images that are stored in Enterprise, see Placing files on a layout using Smart Connection for InDesign and Working with images in Smart Connection for InCopy.

Info: The information presented here applies to the following versions of Smart Connection:

  • Smart Connection 9
  • Smart Connection for Adobe CC
  • Smart Connection for Adobe CC 2014

Read the steps below or view the following video:

Step 1. Use one of the following methods:

For InDesign:

  • With the Selection tool active, double-click the database image on the layout while holding down the Option key (Mac OS X) or Alt key (Windows)
  • Select the placed database image on the layout, right-click it and from the context menu choose Edit Original
  • Select the placed database image on the layout and choose Edit > Edit Original
  • Access the Links panel (Window > Links), select the placed database image in the panel and click the Edit Original button, choose Edit Original from the panel flyout menu, or right-click the file and choose Edit Original from the context menu.

For InCopy:

  • With the Position tool active, double-click the database image on the layout while holding down the Option key (Mac OS X) or Alt key (Windows)
  • With the Position tool active, select the placed database image on the layout and do one of the following:
  • Select the image, right-click it and from the context menu choose Edit Original
  • Select the image on the layout and choose Edit > Edit Original
  • Access the Links panel (Window > Links), select the placed database image in the panel and click the Edit Original button, choose Edit Original from the panel flyout menu, or right-click the file and choose Edit Original from the context menu.

The image opens in the application that has been set up as the default editor for that type of image on your system.

Example: A JPG image will be opened in Photoshop if your system has been configured in such a way that JPG files are always opened in this application.

Step 2. Edit the image in some way.

Step 3. Save the file.

Step 4. (Optional, but recommended) Close the file.

Step 5. Return to InDesign or InCopy.

Smart Connection will detect that the image has been modified and displays the Check-in dialog box to allow you to save these changes to Enterprise.

The Check-In dialog box

Note: You might have to wait a few seconds for the dialog box to appear.

Step 6. (Optional) Update any of the editable fields.

Step 7. Click OK.

The following actions take place:

  • The image is saved to the Enterprise system.
  • The image on the layout is updated with the saved changes.

Troubleshooting


After saving the file and returning to InDesign or InCopy, no dialog appears for saving the file to Enterprise

Make sure that you have opened an image that is saved in Enterprise. The feature will not work for images that are saved elsewhere, such as on your local system.


An error appears in InDesign or InCopy after opening the image:

AppleScript Error (-1728): Preview got an error: Can't get every document.

AppleScript error -1728

This can happen when working on a Mac and the application in which the image is opened does not have a working AppleScript interface for editing the image.

Example: When the image is opened in Preview, the error is shown.

To resolve this, associate all files of that type with an application that does contain the required AppleScript interface (such as Photoshop).

In the following steps, JPEG files are associated with Photoshop:

Step 1. In Finder, locate a JPEG file anywhere on your system.

Step 2. Select the file and do one of the following:

  • Press Cmd + I
  • Choose File > Get Info

The Get Info window appears.

Step 3. Locate the Open With section about half-way down the window.

Step 4. From the list, choose Photoshop.

Mac Finder Open With

Step 5. Click Change All... and confirm that you want to make the change to all similar documents.

Was this article helpful?
0 out of 0 found this helpful / Created: / Updated:
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.