Logo Help Center

Compatibility of operating systems with Enterprise Server

Compatibility of operating systems with Enterprise Server

This article lists the compatibility of operating systems with Enterprise Server.

Notes:

  • For all operating system flavors, it is recommended to use the 64-bit version to gain better performance. However, for Enterprise Server versions 9.x, 10.0.x and 10.1.x, the 32-bit flavors are supported as well.
  • Please also verify that any software that is installed by default by these operating systems such as PHP, Web browsers and so on is also compatible with Enterprise Server.

Windows

Enterprise Server version
Windows version 9.x 10.0.x – 10.1.x 10.2.x
Windows Server 2008 SP2 1, 2 Yes Yes -
Windows Server 2008 R2 SP1 1, 2 Yes Yes -
Windows Server 2012 / 2012 R2 Yes R Yes R Yes
Windows Server 2016 Yes Yes3 Yes

Legend: Yes = combination is supported. Yes R = recommended combination. - = combination of old and new software versions is not supported.

1 Windows 32-bit and 64-bit are both supported. Most recommended is 64-bit because of performance reasons. When using Windows 64-bit, also install SQL Driver 64-bit and IIS 64-bit. For VC9 compiled versions only, PHP and ionCube are available in 32-bit only but IIS 64-bit can run PHP in a 32-bit application pool. Because Enterprise Server runs on PHP it is running 32-bit, even when using a 64-bit version of Windows/IIS. For VC11 compiled versions (and newer), both 32-bits and 64-bits are supported for PHP and ionCube.

2 Service Pack is required by SQL Driver 3.x for PHP.

3 This was tested with Enterprise Server 10.1.2 but is expected to be valid for any version of Enterprise Server 10.0 and 10.1.

When connecting to MS SQL Server

Enterprise Server version
MSSQL version 9.8.x 10.0.x – 10.1.x 10.2.x
ODBC Driver 11 for SQL Server Yes Yes Yes
ODBC Driver 13.1 for SQL Server - - Yes

SQL Driver 3.2 for PHP (PHP 5.4.32 / 5.5.16 / 5.6.4 or higher)

Yes

Yes

-
SQL Driver 4.3 for PHP (PHP 7.0 / 7.1) - - Yes

Legend: Yes = combination is supported. - = combination of old and new software versions is not supported.

Older versions

Mac OS X

Note: The MAMP package can be used for development and demo environments but it is not suitable for production purposes. See www.mamp.info.

Enterprise Server version
Mac OS X version 9.8.x 10.0.x – 10.1.x 10.2.x
OS X 10.9 (Mavericks Server) Yes Yes D1
OS X 10.10 (Yosemite Server 4.0) Yes R Yes D1
Mac OS X 10.11 (Server 5.0) Yes Yes D1
MacOS 10.12 Yes Yes R D1

Legend: Yes = combination is supported. Yes R = recommended combination. - = combination of old and new software versions is not supported. D = Deprecated. tbd = to be determined

1 Support for Mac OS X has been deprecated and is to be removed in a later version. This also includes support for sips, but does not apply to InDesign Server. For new installations and upgrades we strongly recommend to move to Linux or Windows. However, Enterprise Server 10.2 can currently still be used on Mac OS X and is still fully supported.

Older versions

Others

Enterprise Server version
Operating System 9.8.x 10.0.x – 10.1.x 10.2.x
RedHat Linux 6.x / CentOS 6.x Yes Yes -
RedHat Linux 7.x / CentOS 7.x Yes R Yes R Yes R
OpenSUSE 12 Yes Yes -
OpenSUSE 13 Yes R Yes R Yes R

Legend: Yes = combination is supported. Yes R = recommended combination. - = combination of old and new software versions is not supported.

Older versions

Document history

  • 18 December 2017: Added compatibility for Enterprise Server 10.2.x.
  • 18 December 2017: Added compatibility for ODBC Driver 11 for SQL Server.
  • 18 December 2017: Added compatibility for ODBC Driver 13.1 for SQL Server.
  • 18 December 2017: Added compatibility for SQL Driver 4.3 for PHP (PHP 7.0 / 7.1).
Was this article helpful?
0 out of 0 found this helpful / Created: / Updated:
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.