Logo Help Center

Compatibility of PHP with Enterprise Server

 

Compatibility of PHP with Enterprise Server

This article lists the compatibility of PHP with Enterprise Server.

Enterprise Server 10

  Enterprise Server version
PHP version 10.0.0 – 10.0.4 10.0.5 or higher 10.1.0 – 10.1.1 10.1.2 or higher
PHP 5.3
All versions
- - - -
PHP 5.4
Version 5.4.16 to 5.4.x1
Yes 5 - Yes 5 -

PHP 5.5
Version 5.5.16 to 5.5.x7

Yes 2,3 Yes 2,3 Yes 2, 3 Yes 2, 3
PHP 5.6
Version 5.6.14 to 5.6.x
Yes 2,4, 6 Yes 2,4, 6 Yes 2,4, 6 Yes 2,4, 6

Legend: Yes = combination is supported. - = combination of old and new software versions is not supported.

1 Since PHP 5.3, ISAPI is no longer supported. Use FastCGI instead.

2 For Windows, 64-bit versions of PHP are not supported because those are (and will remain to be) experimental.

3 For Windows, only use VC9 or VC11 compiled versions of PHP, else PHP is not compatible with ionCube Loader 4.6.1.

4 For Windows, only use VC9 or VC11 compiled versions of PHP 5.5, or use VC11 compiled versions of PHP 5.6, else PHP is not compatible with ionCube Loader 5.0.14.

5 Supported for Linux only.

6 PHP 5.6 in combination with the Enterprise ProxyForSC feature requires Enterprise Server 9.8.1 or higher.

7 PHP 5.5 is out of maintenance (regular and security), see php.net - Supported Versions. We therefore advice to upgrade to PHP 5.6.

Enterprise Server 9

  Enterprise Server version
PHP version 9.0.x – 9.4.x1 9.5.x – 9.6.x1 9.7.x – 9.8.x1
PHP 5.3 2, 3, 6 Yes 4, 5 - -
PHP 5.4 2 Yes 4, 5 Yes 7,8 Yes 10
PHP 5.5 - Yes 7,8 Yes 7,8
PHP 5.6 - - Yes 7,9,11

Legend: Yes = combination is supported. - = combination of old and new software versions is not supported.

1 See the following links for information about supported and non-supported versions of PHP with each version of Enterprise Server 9.

2 Since PHP 5.3, ISAPI is no longer supported. Use FastCGI instead.

3 When using the Adobe DPS functionality on Windows, use PHP 5.3.6 or higher.

4 For Mac OS X, 32-bit versions of PHP are not supported because ionCube 4.2.2 / 4.6.1 is available for 64-bit systems only.

5 For Windows, only use VC9 compiled versions of PHP, else PHP is not compatible with ionCube 4.2.2 / 4.6.1.

6 The PHP 5.3.29 release marks the end of life of the PHP 5.3 series.

7 For Windows, 64-bit versions of PHP are not supported because those are (and will remain to be) experimental.

8 For Windows, only use VC9 or VC11 compiled versions of PHP, else PHP is not compatible with ionCube Loader 4.6.1.

9 For Windows, only use VC9 or VC11 compiled versions of PHP 5.5, or use VC11 compiled versions of PHP 5.6, else PHP is not compatible with ionCube Loader 5.0.14.

10 PHP 5.4 on Enterprise 9.7 and higher is supported on Linux only.

11 PHP 5.6 in combination with the Enterprise ProxyForSC feature requires Enterprise Server 9.8.1 or higher.

Document history

  • 29 March 2017: Updated the table for Enterprise 10 be better indicate the range of compatible PHP versions.
  • 27 March 2017: Created separate tables for Enterprise 9 and 10.
  • 27 March 2017: Updated compatibility for PHP 5.4 for Enterprise Server 10.
Was this article helpful?
0 out of 0 found this helpful / Created: / Updated:
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.