WoodWing Help Center

Replacing a database image for a file in a different format using Smart Connection

Replacing a database image for a file in a different format using Smart Connection

Info: The information presented here applies to the following versions of Smart Connection:

  • Smart Connection 9.2 or higher
  • Smart Connection for Adobe CC
  • Smart Connection for Adobe CC 2014

It is very common that a placed database image (stored in Enterprise) needs to be edited at various times during the production process.

While editing the image, you might decide to save the file in a different format.

Example: A file in JPG format is opened in Photoshop and after editing the file it contains several layers. In order to preserve the layers, the file is saved in Photoshop format.

See this process demonstrated in this video or read the steps below.

Warning: This method fully replaces the original file. Restoring the original file can be done through the Show Versions > Restore option but because only a limited number of versions are saved (depending on how Enterprise is configured), this version may or may not be available.
Example: A Photoshop file containing several layers is opened in Photoshop and after editing the file it is saved in JPG format. After replacing the file as described below, the only way to get hold of the Photoshop file is by restoring the file to its latest version in which it was still a Photoshop file.

Step 1. Open the file for editing by using one of the following methods:

For InDesign:

  • With the Selection tool active, double-click the database image on the layout while holding down the Option key (Mac OS X) or Alt key (Windows)
  • Select the placed database image on the layout, right-click it and from the context menu choose Edit Original
  • Select the placed database image on the layout and choose Edit > Edit Original
  • Access the Links panel (Window > Links), select the placed database image in the panel and click the Edit Original button, choose Edit Original from the panel flyout menu, or right-click the file and choose Edit Original from the context menu.

For InCopy:

  • With the Position tool active, double-click the database image on the layout while holding down the Option key (Mac OS X) or Alt key (Windows)
  • With the Position tool active, select the placed database image on the layout and do one of the following:
  • Select the image, right-click it and from the context menu choose Edit Original
  • Select the image on the layout and choose Edit > Edit Original
  • Access the Links panel (Window > Links), select the placed database image in the panel and click the Edit Original button, choose Edit Original from the panel flyout menu, or right-click the file and choose Edit Original from the context menu.

The image opens in the application that has been set up as the default editor for that type of image on your system.

Example: A JPG image will be opened in Photoshop if your system has been configured in such a way that JPG files are always opened in this application.

Step 2. Edit the image in some way.

Step 3. Save the file under a different file format, for example by choosing File > Save As.

Notes:

Make sure of the following:

  • Save the file in the same folder as where the original image is saved on your system. This is normally a temporary location which should be automatically accessed when opening the Save window. If not, browse to the following location:
  • Mac OS: /Users/<username>/Documents/SmartConnection.noindex/<InDesign> or <InCopy>/<database ID folder>
  • Windows: C:\Users\<user name>\My Documents\SmartConnection.index\<InDesign> or <InCopy>\<database ID folder>
  • Do not change the name of the file (this is because Smart Connection will present you with a list of files in the different formats in which you have saved the file; only files of which the name is identical to the name of the original file will appear in that list).

Step 4. (Optional, but recommended) Close the file.

Step 5. Return to InDesign or InCopy. A dialog box appears. The file that was edited last is listed first.

The dialog box for choosing the image

Example: When a JPG file was saved as a PNG file, the PNG file will be listed first.

Step 6. (Optional) From the list, choose the file that you want to use.

Tip: If you want to revert back to the original, unedited image choose the file that ends with '(original)'.

Step 7. Click OK. One of the following scenarios will take place:

Scenario #1: The Check-In dialog box appears. This happens when:

  • You have chosen to use the original file and that file has been modified
  • You have chosen to use a file in a different file format

The Check-In dialog box

Continue with the following steps:

Step 8. (Optional) Update any of the editable fields.

Step 9. Click OK.

The following actions will take place:

    • The original image in the Enterprise system is replaced by the image in the new format.
    • The image on the layout is replaced.
    • All files that have the same name as the original image but have a different extension are removed from the temporary folder.

Scenario #2: No Check-In dialog box appears. This happens when you have chosen the original file but no changes have been made to that file. No further steps are necessary.

In the mean time, the following will have taken place:

    • All files that have the same name as the original image but have a different extension are removed from the temporary folder.

Troubleshooting

After saving the file and returning to InDesign or InCopy, the file is not in the list

  • Make sure that you have changed the type of the file, for instance from PSD to JPG. Other changes, such as changing the file name, are not detected.
  • Make sure that you have saved the file to a supported file format. For example: the bitmap format (BMP) is not supported by default by Enterprise. When in doubt, contact your system administrator.

Note for system administrators: The list is populated by comparing the format of the files in the temporary WoodWing folder against the files configured as object type 'Image' in the EXTENSIONMAP of the configserver.php file of Enterprise Server. If the file type is not listed, the file is excluded from the list. To have the file included in the list therefore, define them in the EXTENSIONMAP.

After saving the file and returning to InDesign or InCopy, no dialog appears for saving the file to Enterprise

This could have several causes:

  • The file is not saved in the same folder as where the original image is saved on your system. This is normally a temporary location and can be found here:
  • Mac OS: /Users/<username>/Library/Application Support/WoodWing.noindex/
  • Windows: C:\Documents and Settings\<user name>\Application Data\WoodWing\
  • You have chosen the original file from the list and have made no changes to that file. In that case, checking-in the file is not necessary.
  • You have opened an image that is saved outside of Enterprise, such as on your local system. Make sure that the image is a placed image from the Enterprise system.

An error appears in InDesign or InCopy after opening the image:

AppleScript Error (-1728): Preview got an error: Can't get every document.

AppleScript error -1728

This can happen when working on a Mac and the application in which the image is opened does not have a working AppleScript interface for editing the image.

Example: When the image is opened in Preview, the error is shown.

To resolve this, associate all files of that type with an application that does contain the required AppleScript interface (such as Photoshop).

In the following steps, JPEG files are associated with Photoshop:

Step 1. In Finder, locate a JPEG file anywhere on your system.

Step 2. Select the file and do one of the following:

  • Press Cmd + I
  • Choose File > Get Info

The Get Info window appears.

Step 3. Locate the Open With section about half-way down the window.

Step 4. From the list, choose Photoshop.

Mac Finder Open With

Step 5. Click Change All... and confirm that you want to make the change to all similar documents.

I have canceled the Check-In dialog box. How do I get the window back on screen from which I can choose the file?

When canceling the Check-In dialog box, the images in their different file formats are not removed from the system and are therefore still available. Instead of repeating all steps of converting the image into a new file format, simply do the following:

Step 1. Open the image for editing once more.

Step 2. (Optional) Close the image again.

Step 3. Return to InDesign or InCopy. The window appears from which you can choose the file that needs to be saved.

Was this article helpful?
0 out of 0 found this helpful / Created: / Updated:
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.