Logo Help Center

Elvis 6 action plug-ins setting - requiredPermissionMask

Elvis 6 action plug-ins setting - requiredPermissionMask

The requiredPermissionMask setting is one of the settings of an Action plug-in that can be configured in its configuration file. For more information, see Elvis 6 Action plug-ins - configuration settings.

Required No
Description

Permission mask validation to check if the current selection of assets and/or folders is valid. The plug-in buttons and menu items are enabled or disabled based on the result of the expression. The result of the validation is combined with the result of the enabledExpression check.

For example, when a plug-in can change metadata, you can check if the user has permission to edit metadata on the selected assets.

Basic setting
<action>
    <requiredPermissionMask>...</requiredPermissionMask>
</action>

Examples

A plug-in that needs access to thumbnails an previews

VIEW and VIEW_PREVIEW permissions are required.

<requiredPermissionMask>VP-------</requiredPermissionMask>

A plug-in that needs to change asset metadata

EDIT_METADATA permission is required.

<requiredPermissionMask>----E----</requiredPermissionMask>

A plug-in that needs access to the orignal file

USE_ORIGINAL permission is required.

<requiredPermissionMask>---U-----</requiredPermissionMask>
Was this article helpful?
0 out of 0 found this helpful / Created: / Updated:
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.